Unexpected service outage
Incident Report for CloudCare
Resolved
The issue has been resolved. If you are still experiencing issues, please contact support.
Posted Mar 19, 2018 - 19:19 EDT
Identified
We are experiencing an issue with the login page for CloudCare US. (us.cloudcare.avg.com)

Impact:
• Users will not be able to log in to CloudCare US portal.
• All other services will remain operational.
Posted Mar 19, 2018 - 18:49 EDT