Billing service interruption
Incident Report for CloudCare
Resolved
The issue has been resolved and services have returned to a fully functional status.
Posted May 23, 2018 - 09:42 EDT
Identified
The CloudCare shopping cart is currently experiencing an outage. Services will be restored as quickly as possible.
Impact:
• Users are not able to make NEW purchases ONLY.
• All other services remain operational.
Posted May 23, 2018 - 09:21 EDT
This incident affected: Billing Services.