Billing service interruption UK Region
Incident Report for CloudCare
Resolved
This incident has been resolved. All services are operating normally.
Posted May 25, 2018 - 14:37 EDT
Identified
The CloudCare shopping cart is currently experiencing an outage. Services will be restored as quickly as possible.
Impact:
• Users are not able to make NEW purchases ONLY.
• All other services remain operational.
Posted May 25, 2018 - 09:00 EDT
This incident affected: Billing Services.